Usare iThemes Security con WP Rocket

WP Rocket è compatibile con il plugin iThemes Security.

iThemes Security ha un'opzione che impedisce la modifica dei file (il che è una misura di sicurezza che ha la sua logica). Tuttavia, WP Rocket ha bisogno di permessi di scrittura per poter accedere ai file .htaccess, wp-config.php e anche per creare il file advanced-cache.php e le cartelle cache e wp-rocket-config. I permessi di cartella dovrebbero essere impostati su 755, 775 o anche 777 in alcun piattaforme di hosting. I permessi dei file invece andrebbero impostati su 644 (valori standard di WordPress).

Una volta che installi WP Rocket, assicurati che System Files Protection sia disattivato:

Nel caso in cui tale opzione sia attiva, la cache non verrà attivata e vedrai il messaggio di errore seguente: